Saturday, February 19, 2011

RubyGems 1.5.0 Released: Now Supports Ruby 1.9.2

Ryan Davis has announced the release of RubyGems 1.5.0. It comes just a month after the release of 1.4 which, notoriously, didn't work with Ruby 1.9.2. These problems have now all been ironed out and Ruby 1.8 and 1.9 users alike can safely upgrade (fingers crossed).

RubyGems is the popular (and official - as of Ruby 1.9) Ruby package manager with which most significant Ruby libraries and tools are distributed. The 1.5 release sees it pick up a few bug fixes and some enhancements, including:
  • Ruby 1.9 support
  • Post-build hooks that can cancel the gem install
  • Gem.find_files is now 40% faster (on Ruby 1.9)
  • Better errors for corrupt Gem files, including paths
  • A new UPGRADING documentation file to help with Ruby 1.9-related issues
  • gem update no longer erroneously tries to update RubyGems itself by default
To upgrade to RubyGems 1.5.0, run:
gem update --system 
Alternatively, you can learn more in the new UPGRADING documentation, or if you don't already have RubyGems for some reason, you can download it from



suresh said...

My cousin recommended this blog and she was totally right keep up the fantastic work!

Ruby Development

Post a Comment