Sunday, December 19, 2010

Security Update Released or WordPress 3.03

Why is it that WordPress updates are always released the minute before I want to go to bed? WordPress has just released a new update that brings the version of their popular blogging platform to 3.03. The update is a security update which makes it a mandatory update for all WordPress webmasters
hosting blogs on their own servers,

So what’s the security vulnerability about? The WordPress blog states that it is about issues “in the remote publishing interface, which under certain circumstances allowed Author- and Contributor-level users to improperly edit, publish, or delete posts”.

That in turn means that single-author blogs are not affected by the vulnerability directly. Webmasters should still consider updating right away to prevent future damage or indirect damage if someone manages to get access to user accounts on the blog or the ability to create them.

The issue affects sites that have remote publishing enabled. Sites that do not have it enabled are not affected. Then again, it is always a good idea to update to the latest release to close potential security issues right away.

WordPress admins can check if remote publishing is enabled by going to Settings > Writing in their WordPress admin interface.

The update is as usually available directly in WordPress. Users can update their blogs from within WordPress which is the fastest and most convenient solution, or by downloading WordPress from the official website and installing the update manually.

For Free consultation on regarding RoR Installation, RoR Developers, RoR Development, ROR Programmer log on to


Post a Comment